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Overview

Welcome

Thank you for purchasing a DeckLink broadcast video card. 

We hope you share our dream for the television industry to become a truly creative industry by 
allowing anyone to have access to the highest quality video.

Previously high end television and post production required investment in millions of dollars of 
hardware, however with DeckLink cards, even 10 bit uncompressed is now easily affordable. We 
hope you get years of use from your new DeckLink card and have fun working with some of the 
world’s hottest television and design software!

This instruction manual should contain all the information you’ll need on installing your DeckLink 
capture card, although it’s always a good idea to ask a technical assistant for help if you have not 
installed hardware cards into computers before. As DeckLink uses uncompressed video and the 
data rates are quite high, you’ll need fast disk storage and a high-end PC.

We think it should take you approximately 10 minutes to complete installation.  Before you install 
DeckLink, please check our website at www.blackmagic-design.com and click the support page to 
download the latest updates to this manual and DeckLink driver software. Lastly, please register 
your DeckLink when downloading software updates. We would love to keep you updated on new 
software updates and new features for your DeckLink. Perhaps you can even send us your latest 
show reel of work completed on your DeckLink and any suggestions for improvements to the 
software. We are constantly working on new features and improvements, so we would love to hear 
from you!

Grant Petty

CEO Blackmagic Design
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Before installing a DeckLink card

Hardware Installation

Remove the power plug from the back of your PC.  This is a safety precaution before opening 	1.	
your computer. Ensure that you are statically discharged by using a static strap.

Remove the side cover of your PC to gain access to the PCI slots.2.	

Remove your DeckLink PCIe card from the protective static bag making sure you don’t touch 3.	
the gold connectors on the base of the card. These precautions should be taken when handling 
any PCI card.

Find a spare PCI, PCI-X or PCIe slot. Remove the metal port access cover, and screw, from the 4.	
back of your PC.

Insert your DeckLink PCIe card and ensure that it clicks into place.5.	

Secure the card by the screw or clamping device.6.	

The procedure for installing a RAID controller card is similar to the above.7.	

Now replace the side cover of your PC. Reconnect the power and start up the computer.8.	

Note: DeckLink standard defintion PCIe cards require a x1 lane PCI Express slot or faster. Some 
DeckLink high definition PCIe cards require a x4 lane PCI Express slot or faster and others only 
require a x1 lane PCI Express slot or faster. DeckLink HD Pro PCI-X requires a 133MHz PCI-X slot. 
Please see www.blackmagic-design.com/support for the latest list of supported motherboards for 
use with DeckLink cards.

Installing a DeckLink PCIe card

1.	 Shutdown and remove the power plug from the back of your PC. This is a safety precaution 
before opening your computer. Ensure that you are statically discharged by using a static strap.

2.	 Remove the chassis cover of your PC to gain access to the PCI Express slots.

3.	 Remove your DeckLink PCIe card from the protective static bag making sure you don’t touch the 
gold connectors on the base of the card. Although there are no electronics on this card, these 
precautions should be taken when handling any PCI Express card.

4.	 Find a spare PCIe slot within the PC. PCIe x1 lane cards should work in any slot. PCIe x4 lane 
cards require a x4 lane or faster PCI Express slot. Remove the metal port access cover and screw, 
from the back of your PC.

5.	 Insert your DeckLink PCIe card and ensure that it clicks firmly into place. 

6.	 Secure the card with the screw and replace the side cover of your PC. 

Installation

Install a DeckLink PCIe x1 or x4 lane card in a 
compatible PCI Express slot as shown in the 
above picture. The DeckLink HD Extreme 2 also 
has an HDMI bracket, which installs in any spare 
port, and connects to the rear of the card with 
the supplied HDMI cables.  
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Installation

Before installing a DeckLink card

7.	 After installing your DeckLink PCIe card and closing the side cover on your PC, attach the supplied 
DeckLink breakout cable to to the external multi-pin connector on your DeckLink card. Some card 
models ship with both professional and consumer breakout cables for connecting to different 
video hardware. Attach the appropriate breakout cable for your needs.Installation

Installing the HDMI bracket

The DeckLink HD Extreme 2 includes an HDMI bracket. After installing the DeckLink HD Extreme 2 
card in a x4 lane PCIe slot, you will need a spare slot to install the HDMI bracket. Some PC’s include 
a double-width graphics slot in the x16 lane slot. If you have a regular-width graphics card in this slot, 
you can install the HDMI bracket in the spare port which would have been used by a double-width 
graphics card.  If that port is already occupied by a double-width graphics card, use a spare slot to 
install the HDMI bracket. If you don’t need HDMI input and output, there is no necessity to install 
the HDMI bracket.

Some computer cases provide a PCI clamp which is designed to secure all PCI Express cards without 
the need for screws. The clamp does not always firmly secure the HDMI bracket and so we have 
included 6 screws with your DeckLink HD Extreme 2. Use these screws, in place of the PCI clamp, 
to firmly secure all your PCI Express cards, port access covers and the HDMI bracket belonging to 
DeckLink HD Extreme 2.

After installing and securing the HDMI bracket, loop the included HDMI cables around any other 
installed cards and plug them into the rear of the DeckLink HD Extreme 2 card. HDMI input is the 
lower connector and HDMI output is the upper connector. You may wish to secure any excess cable 
length by using a cable tie to neatly hold it in place.

Note: Connecting audio and video cables to the DeckLink can be done at any time while the unit 
is powered on or off. You can leave the PCI Express card in the computer when the PCI Express 
cable is disconnected. It will then be ready to reconnect quickly when you need to use DeckLink as 
a capture and playback device again.

Attach the supplied DeckLink breakout cable to the 
DeckLink card. The DeckLink HD Extreme 2 card 
also includes a HDMI bracket as pictured above.
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Installation

Installation

Installing the software

Contents

The DeckLink software installer will install the following components for you:

Blackmagic DeckLink drivers��
Blackmagic Media Express application��
Blackmagic DeckLink Control Panel��
Blackmagic AVI and QuickTime�� ™ codecs
Project presets for Adobe Premiere Pro��
Blackmagic DirectShow�� ™ SDK
Blackmagic Disk Speed Test��
Blackmagic FrameLink��
DeckLink Utility��

DeckLink software

1.	 The CD supplied with the DeckLink contains the DeckLink software. Before you install, ensure 
you have the very latest driver. Visit www.blackmagic-design.com/support

2.	 Open the “DeckLink Installer” folder and launch the “DeckLink Installer” application.

3.	 The drivers will now be installed on your system. A warning will appear that “Windows can’t 
verify the publisher of this driver software” or about “logo certification”. Click Continue 

Anyway to ignore this warning.

4.	 You will see a dialog bubble saying “found new hardware” and the hardware wizard will appear. 
Select “install automatically” and the system will find the required DeckLink drivers. You will then 
receive another dialog bubble saying “your new hardware is ready for use.”

5.	 Now restart your machine to enable the new software drivers.

Automatic firmware updating

After your computer has restarted, the software will talk to the DeckLink to see what firmware is 
running in it’s hardware. If the firmware is not the same as the DeckLink software requires, you’ll be 
asked to download the correct version. This is automatic, and all you need to do is click OK to start 
the update. After the firmware updates, restart your computer and to complete the process.

Programmable firmware let’s us release new features and we can also update your DeckLink for 
greater compatibility with latest third party software tools.

DeckLink Setup Wizard.

Click “Continue Anyway”.

Restart your PC!
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Installation

Installation

Testing your installation

Testing

To check the installation has been successful on most DeckLink cards with Windows XP:

1.	 Go to the Control Panel and open Display. Click on the Settings tab. You should see an 
extra display which represents the extended desktop feature of your DeckLink. The size of 
the DeckLink display will appear differently to your computer display, and may be in HD or SD 
resolution. Select the second display. DeckLink models, which support high definition video 
with a x1 lane PCI Express card, do not include an extended desktop and will not show an extra 
display in the Settings tab.

2.	 Then enable Extend my Windows desktop onto this monitor

3.	 Go to  the Control Panel  and open DeckLink. Check the SDI, Analog Component, Composite 
NTSC/PAL, and the HDMI outputs for desktop video. 

The DeckLink HD Extreme 2 has SDI, Component analog, Composite analog and HDMI video 
outputs as well as SDI, HDMI, XLR analog and AES digital audio outputs. Other models of 
DeckLink cards have some but not all of these video and audio outputs.

Note: You won’t see any video on the composite analog NTSC/PAL outputs if the desktop is set to 
HD or 2K modes. You won’t see any video on the component analog outputs if the desktop is set 
to 2K modes. A 2K monitoring solution, such as HDLink Pro and a 30” monitor, is required to view 
2K-SDI video output from hardware such as DeckLink HD Extreme 2 and Multibridge Eclipse.

4.	 Check audio output channels 1 & 2 for audio playback. The same audio should be heard on all 	
	 the audio outputs provided on your model of DeckLink card, eg: analog XLR, AES/SPDIF, HDMI  
	 and SDI. If this is all working well, you know your DeckLink is working correctly.

Display Properties.
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Blackmagic Software

Blackmagic Software

Using Blackmagic Media Express

Blackmagic Media Express is a simple utility for frame-accurate capture and playback with your 
broadcast tape deck. It uses the RS-422 port on DeckLink and DeckLink hardware to control the 
deck using the Sony™ RS-422 protocol.

It’s great for use with applications such as Adobe After Effects™ and eyeon Fusion™ which do not 
include their own deck control capabilities.

Blackmagic Media Express supports capture and playback of AVI files in the following Blackmagic 
formats:

Uncompressed 10-bit RGB (.avi)��
Uncompressed 10-bit YUV (.avi)��
Uncompressed 8-bit YUV (.avi)��
Compressed Motion JPEG (.avi)��

Playback of the following formats is also supported:

Windows Media Video (.wmv)��
Blackmagic QuickTime Uncompressed 10-bit RGB (.mov)��
Blackmagic QuickTime Uncompressed 10-bit YUV (.mov)��
Blackmagic QuickTime Uncompressed 8-bit YUV (.mov)��

 
Playback of other video formats is likely to work as long as the relevant codec is present on the 
computer and the video is in a standard TV resolution and frame rate, eg 720 x 486 at 29.97 fps. 
Computer resolutions such as 640x480 cannot be used. Audio must use the television standard 
sample rate of 48Hz and 24 bit.

This simple utility can capture or play back one video clip at a time. Put Clip

Setting Up

1. Go to the Windows Start menu and select All Programs > Blackmagic Design > DeckLink 	
  > Media Express.

2. Open Edit > Preferences and select the desired video format and compression type from the     
    drop down menu.

3. Set your disk array as the Capture Location and enter a Capture Filename to apply to any captured  
clips or frame grabs.

Media Express preferences.

Media Express interface.
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Blackmagic Software

Using Blackmagic Media Express

Playback

1. 	Click on the Playback tab.

2. Select File > Open Media File and choose the video file you wish to play back. Alternatively 	
	 drag the desired video clip directly in to the Playback window. The movie will appear in the 	
	 Playback window.

3. Click the Play and Stop buttons to start and stop playback. You can also use the standard keys  
	 used for video playback to start, stop, play forwards and play backwards at different speeds,  
	 i.e. “<spacebar>”, “j”, “k” and “l” keys.

4. 	You can also scrub the clip by dragging the playhead along the timeline.

Video playback can be set to loop playback, or play once, by setting the playback switch as desired.

Inserting to Tape

1.	 Connect an RS-422 cable between the video deck and the DeckLink or DeckLink RS-422 port 	
	 to ensure that timecode is available.

2. 	Open the clip that you wish to print to tape.

3. 	Ensure that the video deck is configured to accept the video format of the clip, e.g. one cannot 	
	 send a PAL clip to an NTSC-only deck.

3. From the View menu choose Deck Control. The Deck Control window will open.

4. Enter the timecode of the desired in-point. Blackmagic Media Express will use the clip duration to  
	 automatically calculate the out point.

5. Click Put Clip.

Capturing Clips

1. Click on the Capture tab

2. Connect an RS-422 cable between the video deck and the DeckLink or DeckLink RS-422 port to 
ensure that timecode is available.

3. Go to the Edit menu and choose Preferences.

4. Configure the capture settings to match the video format and compression type you intend to 
capture, e.g. HD 1080i 59.94 and Uncompressed 10-bit YUV. Set the capture location. Uncompressed 
video should always be captured to a disk array.

5. Click Put Clip.

Media Express “Capturing to Disk”.

Deck Control interface.

Blackmagic Software
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Blackmagic Software

Using Blackmagic Media Express

There are two ways to capture clips:

A. Record Now

Captures video and audio instantly. (Control-R)

The REC button lights up during capture. Click the STOP button or press the Esc key on your 
keyboard to stop the capture.

B. Get Clip

	Captures frame accurate timecode, video, audio to “in” and “out-points” set by the user.

	From the View menu choose Deck Control. The Deck Control window will open.

Connect an RS-422 cable between the video deck and the DeckLink or DeckLink RS-422 port 	 t o 
ensure that timecode is available.

	Click the Play and Stop buttons in the Deck Control window to start and stop playback of the video 
deck. Your video deck will respond to the standard keys used for deck control, i.e. spacebar, “j”, “k” 
and “l” keys. In and Out points can be set using the “i” and “o” keys while playing the tape.

Grab Frame

Captures a frame of video from the video input.

	1. Click on the Capture tab

2. Go to the Movie menu and choose Grab Frame As. (Control-G)

	3. The frame grab will be captured as a .bmp file.

Blackmagic Software
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Blackmagic Software

Blackmagic Software

Using Blackmagic FrameLink

Blackmagic FrameLink™ provides seamless DPX support using uncompressed AVI movies. 

The key to understanding FrameLink, is when you mount a movie file with FrameLink it appears as 
a virtual drive full of DPX frames from the movie. This virtual drive acts as a container for the DPX 
sequence. Any frames modified will be automatically written back into the movie when the frame 
is saved.

FrameLink totally eliminates the time wasted using simple movie to image-sequence conversion 
utilities. FrameLink is great for using software that only supports still frames, or simply open individual 
media file frames in Photoshop™ for dirt and scratch removal, then save the frames back into the 
movie file for instant playback. If an audio track is included with the media that you are converting to 
a DPX sequence, the length of the sequence cannot be modified. To add and remove DPX frames 
from a sequence, the audio tracks should be removed and restore later in your NLE.

Supported File Formats

Windows AVI and Blackmagic™ uncompressed QuickTime™ files can be used with FrameLink, 
including 8-bit & 10-bit YUV HD and SD, as well as 10-bit RGB 4:4:4 HD.

Mounting a FrameLink Volume

1.	 Right click on an AVI file and select Mount with Blackmagic FrameLink

The newly mounted drive will appear as next available drive letter. This volume will contain all the 
frames of the AVI movie in DPX format.

Creating a New Movie from DPX Files

1.	 Right click on the work area and select New > Blackmagic FrameLink Movie and format. 
(Matching the format of your existing DPX sequence.)

Note: New movie will appear both as a new network drive and as a file.

2.	 Copy the DPX file sequence to the appropriate drive letter.

Note: You can save your DPX files from any application to the FrameLink volume, or simply drag 
and drop the files into the FrameLink volume.

Unmounting a FrameLink Volume

1.	 Deselect network drive.

2.	 Right click drive letter and select Unmount from Blackmagic FrameLink

Mounting FrameLink volume.

New FrameLink movie.

Unmounting FrameLink volume.
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Blackmagic Software

Blackmagic Software

Setting Blackmagic Preferences

DeckLink preferences are located in the DeckLink Control Panel. Different DeckLink models have 
some different features. Any preferences not available to your DeckLink card will be grayed out and 
unavailable. The following preferences contain options for setting up your DeckLink.

Settings

Input and Output connections��

NTSC Setup��

Field Jitter��

4:4:4 color mode��

Black reference output during capture��

DeckLink Extended desktop��

Reference Output Timing (Genlock)��

Processing

Down conversion��

Up conversion��

Lookup Table��

VITC Reader A Frame - 3:2 Pulldown Removal��

VANC input��

Video Levels

Calibrate Analog Video In��

Calibrate Analog Video Out��

Betacam/SMPTE level switch��

Audio Levels

HiFi/Professional Audio Levels��

Analog Audio Input Levels��

Analog Audio Output Levels��

AES/EBU Input Reference Level��

AES/EBU Output Reference Level��

Control Panel.

DeckLink Control Panel.
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Blackmagic Software

Setting Blackmagic Preferences

DeckLink video and audio output connections

All of the video and audio outputs of DeckLink cards are active all of the time and the only choice 
you need to make on some models is between component (Y,R-Y,B-Y) analog video, S-Video or 
composite NTSC/PAL analog video as they use shared connectors.

The SDI, HDMI and component (Y,R-Y,B-Y) analog video outputs support HD and SD video. 
S-Video and composite analog video do not support high definition video and so you will not 
see video on these outputs when working with HD video.

S-video is supported on some HD models of DeckLink cards and may require the use of an 
inexpensive S-video adapter cable. See the connection diagrams for S-video towards the end 
of this manual.

DeckLink Studio switchable audio outputs

The DeckLink Studio has switchable audio outputs. You can choose to output:

4 analog and 2 AES/EBU audio channels, or��

2 analog and 6 AES/EBU audio channels��

DeckLink video and audio input connections

Your DeckLink model may support some or all of the following combinations:

SDI Video & SDI Audio��

SDI Video & AES/EBU Audio��

SDI Video & Analog XLR Audio��

HDMI Video & HDMI Audio��

HDMI Video & AES/EBU Audio��

HDMI Video & Analog XLR Audio��

Y, R-Y, B-Y Video & AES/EBU Audio��

Y, R-Y, B-Y Video & Analog XLR Audio��

NTSC/PAL (Y In) & AES/EBU Audio��

NTSC/PAL (Y In) & Analog XLR Audio��

S-Video & AES/EBU Audio��

S-Video & Analog XLR Audio��

Blackmagic Software

Video and Audio Output Connections.

Video and Audio Input Connections.



14

Blackmagic Software

Setting Blackmagic Preferences

Reference Output Timing

Genlock, also known as black burst, reference or house sync is used to lock various equipment in 
your facility to the same timing point. When two or more video devices are connected to the same 
sync signal, their video signals can be switched without jumping or rolling. This is critical when 
connecting equipment in large post production facilities and broadcast stations.

To change video to reference timing:

1.	 Open the DeckLink control panel.

2.	 Select the Settings tab and adjust the Set reference output timing for timed output 
until the picture locks and is no longer rolling on the display.

HDTV Up/Down Conversion

The software drivers included with DeckLink, can be used to downconvert high definition to NTSC 
or PAL video in real time during capture or playback. They also provide upconversion on capture. 
Select the desired option from the output or input processing menus under the Processing tab.

Output Processing
HD to SD Letterbox 16:9��

HD to SD Anamorphic 16:9��

720p HD to 1080i HD��

Output Processing for DeckLink cards with permanent downconversion.
HD to HD and SD Letterbox 16:9��

HD to HD and SD Anamorphic 16:9��

HD to HD and SD Center Cut 4:3��

Note: Permanent down conversion introduces a 2 frame delay on the SD-SDI output. To ensure 
accuracy, adjust the playback/timecode offset options when performing an insert or assemble edit 
to tape with Premiere Pro or Blackmagic Media Express.

Input Processing
1080i HD to SD Letterbox 16:9��

1080i HD to SD Anamorphic 16:9��

720p HD to SD Letterbox 16:9��

��

720p HD to SD Anamorphic 16:9��

SD Letterbox 16:9 to HD��

SD Anamorphic 16:9 to HD��

Genlock timing adjustment.

HDTV Up/Down Converter preferences.

Blackmagic Software
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Blackmagic Software

Lookup Tables (LUT’s) in DeckLink HD Extreme 2 for Windows

DeckLink HD Extreme 2 can use 1D or 3D LUT’s during playback. Lookup tables can be used for 
standard definition and high definition video as well as 2K film.

1D LUT’s are useful for altering the brightness of an image but do not affect color. They are often 
used when working with log video so that the image can be displayed on screen as normal linear 
video. Built-in 1D LUT’s are provided for log to linear conversion when playing video captured from 
Panasonic Cinegamma™ and Viper Filmstream™ cameras.

3D LUT’s provide the ability to increase and decrease the amount of color in each color channel, 
independently from brightness. This allows for precise color grading to ensure a video monitor 
matches the color printed to tape or film.

How to use Lookup Tables in DeckLink

When the System Preferences are opened to access the DeckLink lookup table settings, your 
broadcast monitor will usually stop showing any video being played and instead will show an 
extended desktop. It is possible to replace the extended desktop, with the last played frame of 
video, so that adjustments to lookup tables can immediately be seen on the frame of video.
To use this feature, open the DeckLink Control Panel. Under the Settings tab, look for, “When not 
playing video, send ... to all the video outputs.” This setting is usually set to Extended Desktop or 
Black depending upon your personal preference. Switch it to “Last Played Frame” and then restart 
the computer.

After the computer has restarted, use your preferred video software application to play some 
video. The last played frame of video should remain on your broadcast monitor. Open the DeckLink 
Control Panel and then click on the Processing tab. A Lookup Table button is available for output 
processing and this can be used even when all other processing functions are set to “Off”. Click on 
the output Lookup Table button and then activate the Enable Lookup Tables checkbox.

The lookup table interface in DeckLink can be adjusted using a method similar to that used for 
image adjustment with the Curves feature in Adobe Photoshop™. The horizontal axis of each 
graph represents the original color input values and the vertical axis represents the new colour 
output values. When first opened, each lookup table displays a straight diagonal line because the 
color values have not yet been changed.

Changes made to the lookup tables can immediately be seen on all SDI, analog and HDMI outputs 
of the DeckLink card. Changes are saved to the DeckLink preferences by clicking the OK button. 
Lookup tables can be reset to original values by clicking the Reset Unity button. Lookup table 
processing can be disabled by deselecting the Enable Lookup Tables checkbox.

Enable Last Played Frame.

Click on the Lookup Table button.

Blackmagic Software
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Importing and exporting 3D LUT’s

DeckLink HD Extreme 2 supports the popular Autodesk .3dl, IRIDAS .itx and IRIDAS .cube lookup 
table formats when importing 3D LUT’s.

3D LUT’s can also be exported from DeckLink in the .cube format. DeckLink uses the .cube format 
to store 3D LUT’s internally as this is a most memory efficient way to store complex lookup tables. 
Both 3D LUT’s created with curves in the lookup table interface, and 3D LUT’s imported from .3dl, 
.itx and .cube files, are exported from DeckLink in the .cube format.

The .cube file format is fully compatible with the following Blackmagic Design products which 
share the same LUT format: DeckLink HD Extreme 2, DeckLink Eclipse, DeckLink Pro (October 
2007 model) and HDLink Pro.

Importing and exporting 1D LUT’s

DeckLink HD Extreme 2 can import 1D LUT’s. The 1D file format is any tab-delimited text file with 
red, green and blue values for each record and the first line (title line) is skipped. Lookup tables 
need to be 1024 records long with the first line reserved for the title line.

1D LUT’s can also be exported from DeckLink HD Extreme 2 in the same text format mentioned 
above. Both 1D LUT’s created with the curves in the lookup table interface, and 1D LUT’s imported 
from text files, are exported from DeckLink in the same text format.

The 1D LUT text file format is fully compatible with the following Blackmagic Design products 
which share the same LUT format: DeckLink HD Extreme 2, DeckLink Eclipse, DeckLink 
Pro (October 2007 model), DeckLink Extreme (DVI output), HDLink Pro, HDLink and  
DeckLink HD Pro 4:4:4 (PCI-X).

Blackmagic Software

Load Lookup Table from File.

Load Built-In Lookup Table.

Lookup Table interface.
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Blackmagic Software

Setting Blackmagic Preferences

Black Video Output

This setting allows DeckLink to output a stable black signal on one video output, while outputting 
video on the other output. Black Video Output is used for video referencing a deck when you don’t 
have a sync generator available. This allows the stable black video output to connect to the deck, 
and then by setting the deck to “input reference” you can operate without a sync generator. If 
you’re not using this mode, disable this setting to enable audio monitoring during capture. 

NTSC setup

The NTSC composite video used in the USA, and some other countries uses 7.5% setup. However 
setup is only used in composite video, but is never used in SDI video. Your DeckLink will handle 
adding and removing setup from NTSC video automatically for you. The USA and countries that use 
7.5% setup should enable this setting; if you’re working in Japan and countries that don’t use this 
setup, leave this set to 0 IRE setup. The PAL and high definition standards do not use this setup.

Video Desktop

If your DeckLink card includes the extended desktop feature, this setting allows DeckLink to act 
as a display device with the desktop appearing out of the video outputs. This setting allows the 
desktop mode to be turned on and off and any change requires a restart. It’s important that you set 
the desktop mode to the same standard as your video capture and playback, or you will get slower 
switching between capture and playback modes, as the monitors need to re-lock.

If you don’t want to use the Extended Desktop feature, set this option to Black and then restart  
the computer.

If you’re adjusting LUT’s on some DeckLink models, set this option to Last Played Frame so you can 
observe the effect of any adjustment to LUT’s.

The video desktop feature is supported in Windows XP™. It is not available in Windows Vista™.

NTSC Setup.

Video Desktop.

Black Video Output.

Blackmagic Software
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Blackmagic Software

Setting Blackmagic Preferences

Video Output Behavior

Remove Filter Jitter
“Remove field jitter when video is paused” allows DeckLink to display only a single field when 
paused, while turning this mode off will display a complete frame in pause. Single field is similar to 
how Betacam SP decks work when paused, eliminating field flicker from paused images. 

If you’re doing work without interlaced video, such as animation, then you can turn this mode off  
so you can see both fields in full resolution for best quality. Regardless of this setting, you always  
get the correct full frame dual field output when in playback mode, as this setting only effects 
paused video. Video Output Behavior.

Blackmagic Software
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Blackmagic Software

Setting Blackmagic Preferences

Preserving Blanking Data or VANC

This feature lets you use up to 3 video lines at the top of a captured movie file to store any 3 lines 
from vertical blanking. This allows 3 line timecode, VITC (vertical interval test signals) subtitle info or 
any other VANC data to be preserved during capture. These lines are then inserted back into the 
video blanking when the file is played back.

To preserve VANC data:

1.	 Open the DeckLink control panel.

2.	 Select the VANC and 3:2 Pulldown tab and tick the On check box for video line 1, 2 or 3 
depending on how many blanking lines you want to capture.

	 Note: Video file line 1 needs to be enabled for lines 2 and 3 to work.

Because these lines can be passed to the application, a developer could write software to read the 
VANC data and use it for various purposes, e.g. 3-line timecode and audio chasing, or other uses.

An example of VANC data is 3-line timecode, which uses lines 18, 19, and 20 in NTSC or lines 19, 
20 and 21 in PAL. 3-line timecode, as used in AATON™ equipped telecine suites, featuring audio 
timecode and keycode information along with the normal timecode numbers.

VANC preferences.

Blackmagic Software
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Blackmagic Software

Blackmagic Software

Blackmagic Disk Speed Test

If you want to check your disk array speed, Blackmagic Disk Speed Test can be run to check the array 
speed, and to provide the results in video frame rates. This makes it much easier to understand 
how various disk arrays will handle video capture and playback at various video resolutions and 
frame rates.

Disk Speed Test provides more accurate results for large disk arrays, as often the manufacturer 
provided speed results only check small data blocks; so you only get an indication of the cache 
speed of the disk and not the sustained data rate of the disk. Video uses sustained data rates and 
only Disk Speed Test provides a long burst of data for more accurate results. 

When using Disk Speed Test, you need to account for disk seeking, so it’s best to add a healthy 
margin to the results. If a disk array tests at 32 frames per second HD 1080, it doesn’t mean you can 
do 29.95 HD capture and playback, as the margin is too tight. However it should do 24 fps ok.

Disk arrays

If you intend to run your disk array as a software stripe, you will need to make sure that ‘host RAID’ 
is disabled. Use the “Disk Management” tool in “Computer Management” within Windows™ 
to set up your software RAID, or refer to third party instructions when using pre-configured 
hardware RAIDs. 

Further information can be obtained via the Windows™ Help and Support. Search and review the 
section on “Dynamic Disks”. This section will provide you with information on how to convert a 
basic disk to dynamic disk and configuration steps on striping your disk array. 

Disk Management.

Disk Speed RAID results after testing a disk array.
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Third Party Applications

Third Party Applications

Adobe Premiere Pro

Adobe Premiere Pro™ is a powerful real-time video and audio non-linear editing application. Full 
presets for Premiere Pro are included with DeckLink and will have been automatically loaded into 
your system during the installation process. Premiere Pro must be installed on your system before 
running the DeckLink installer.

Setting Up

1.	 Launch Premiere Pro.

2.	 Open a New Project

3.	 Select the appropriate Blackmagic preset for your project. e.g. NTSC, PAL, HDTV or 2K.

4.	 Type the name of your project.

5.	 Select your disk array as the location for your media and click OK

Playback

As a quick test to make sure everything is connected correctly, use the Premiere Pro test media (bars 
and tone). Copy a test clip, which matches the format of your project to your disk array e.g. NTSC 8 
bit. Take your media from within your Premiere Pro project and drop it into the timeline. You should 
now see the image on both your computer desktop and your DeckLink output. If you can’t see 
any video on your DeckLink output, check the connections again and ensure you have the correct 
output settings configured in both the DeckLink and Displays control panels. SDI, HDMI and analog 
outputs are always active.

Capture

To capture choose: File > Capture (F5)

To immediately capture, click the red record button [G]. If you wish to log the clip, enter the desired   
“In and Out points” using either the “In” and “Out” buttons, or manually, by typing in the timecode 
and clicking “Log”. The empty clip will now appear in the bin window. Repeat this until you have 
logged all of the clips you wish to batch capture.

Batch Capture

Select the clips you wish to capture by drag selecting or shift/click each clip. Then go to and choose: 
File > Batch Capture. To set handles on the clips go to the batch capture window menu and 
type the number of additional frames you require at the start and end of each clip.

Adobe Premiere Pro.

New Project.

Capture.
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Third Party Applications

Third Party Applications

Adobe Premiere Pro

Audio

DeckLink features support for ASIO audio output drivers. This allows Premiere Pro to use DeckLink 
as an ASIO audio output device. When you first start your Premiere Pro project, make sure you select 
DeckLink Audio. This can be configured through Edit > Preferences > Audio Hardware  

You can also select the mix of the multi-channel audio from the Audio Output Mapping menu.

Export to Tape

To export to tape, select the sequence you require File > Export > Export to Tape

Insert editing requires an unbroken timecode over the full length of the project you’re laying to 
tape. This is referred to as “blacking the tape”.

In assemble mode the tape needs only to be “blacked” until a point just beyond the start time of 
the project. As assemble editing erases the tape ahead of the record heads, it should not be used 
where other projects already exist on the tape after the out point of your edit.

When editing to tape, the software waits at the first frame of your program for the deck to drop into 
record at the predetermined timecode. At that exact moment, the program begins to play and the 
edit is completed. Should you find that either the first frame of your program is repeated or lost 
during the edit to tape procedure you will need to adjust the playback offset to bring the deck and 
your computer into sync. You should only need to do this once with any combination of deck and 
computer – and the setting will then stay correct.

Now, simply enter the desired in point and offsets if required, and click OK

Device Control

Selection of the Serial Device Control is configured via:
Edit > Preferences > Device Control

Set the Device Control to DeckLink Device Control. The Options button is disabled as these 
settings are automatically detected and configured when you choose DeckLink Device Control.

Audio Output Mapping.

Export to Tape.

Device Control.
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Third Party Applications

Adobe After Effects

It’s very easy to setup playback and rendering in Adobe After Effects™ for a complete broadcast and 
design workstation that connects direct to decks for capture and playback of clips. DeckLink also 
supports real time preview while working on your compositions. 

First, open Adobe After Effects™ and select the television standard frame size and frame rate you 
wish to work with.

How to use DeckLink as a Preview Output Frame Buffer

To allow your Adobe After Effects™ composition to be displayed in real-time from your DeckLink 
Card, go to Edit > Preferences > Video Preview. Set the Output Device to Blackmagic 
Video Output and then select the desired Blackmagic RGB output mode. This lets you view your 
Adobe After Effects™ compositions in video colorspace on your broadcast monitor as you work. 
This means you will always see the correct color and interlace when working, and you don’t have to 
wait until your composition is rendered to see what it looks like when output as video.

Create a New Composition

Go to the “Composition” menu and select Composition > New Composition (Control + n) In the 
dialogue box, select an appropriate television standard from the pulldown menu. Click OK

For NTSC 720 x 486, select lower field first��
For PAL 720 x 576, select upper field first for uncompressed video��
For PAL DV, select lower field first��
For HD 1080i select 1920 x 1080, select upper field first��
For HD 1080 PsF select 1920 x 1080, select No Fields��
For HD 720p select 1280 x 720, select No Fields��

Rendering

When you have completed your composition, you will need to render to a pixel format supported 
by DeckLink. Below is a list of supported codecs:

Blackmagic QuickTime�� ™ RGB (10 bit uncompressed)
Blackmagic QuickTime�� ™ (10 bit uncompressed)
Blackmagic QuickTime�� ™ (8 bit uncompressed)
Apple QuickTime�� ™ PhotoJPEG (compressed)
Apple QuickTime�� ™ DV - NTSC (compressed)
Apple QuickTime�� ™ DV - PAL (compressed)

Adobe After Effects.

Video Preview preferences.

Third Party Applications
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Third Party Applications

Adobe Photoshop

DeckLink includes Adobe Photoshop™ plug-ins, so you can directly capture and output still 
frames from within the Photoshop™ application itself.

If you’re working with 10 bit HD/SD-SDI, you can even import and export 16 bit Photoshop™ 
images for full quality. Use DeckLink keying to export and key graphics from the video input 
using Photoshop™ alpha channels.

Import an image into Photoshop

1.	 From Photoshop select File > Import > Blackmagic Image Capture

2.	 Select the “Video Input Format” and the “Image Bit Depth” and select Capture Image.

Export an image from Photoshop

1.	 Select File > Export > Blackmagic Image Export 

2.	 Select Video Output Format and then Output Image.

Note: Once you have set the options in the “Export” window, each subsequent Export will not 
display the window so you can output frames much faster. However, if you would like to change 
your export formats, hold the Ctrl key when selecting export.

Image Capture.

Adobe Photoshop.

Image Export.
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Supported File Formats

Uncompressed data rates for capture and playback

The data rates for uncompressed video are quite high, and listed below are minimum recommended 
disk requirements for uncompressed standard definition and high definition video.

Uncompressed 10 bit YUV (4:2:2)

Standard Definition

Frame Size MB per second MB per minute GB per hour

720x486/29.97fps 27 1 600 94

720x576/25fps 26 1 582 93

High Definition

1280x720p/60fps 141 8 438 494

1920x1080/24PsF 127 7 594 445

1920x1080/50i 132 7 910 463

1920x1080/60i 158 9 482 556

Uncompressed 10 bit RGB (4:4:4)

High Definition

1280x720p/60fps 211 12 656 742

1920x1080/24PsF 190 11 391 667

1920x1080/50i 198 11 865 695

1920x1080/60i 237 14 238 834

Due to disk seeks, when calculating the data rates required for your disk system, it is a good idea 
to add a safety margin due to fluctuations in disk speed. Disk speeds can be increased by adding 
more disks.

Serial ATA (SATA) disks can reduce to half their speed as they become full, so in a 2-disk SATA array 
you should aim for a 100% safety margin. In an 8-disk SATA array, a 30% safety margin should be 
adequate. SCSI disk arrays seem to display less fluctuation and so a 20% safety margin should be 
adequate for an 8-disk SCSI array. Generally the more disks in the array, the better.

Note: Although other vendors and third parties may provide different data rates for uncompressed 
video, the above recommendations are tested for use with DeckLink.
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Troubleshooting Video Capture and Playback

Using your DeckLink as a capture and playback solution when connected to a computer is exciting, 
but also complex due to the huge range of different software applications. Video data rates are 
also very high, so the disk array you use for video storage can have a big impact on your system’s 
performance.

Information about a wide range of disk array solutions and compatible application software would 
be outside the scope of this manual, however there are three ways to get more information.

There are four steps to getting help.

1.	 Check out the Blackmagic Design website www.blackmagic-design.com/support for the latest 
support information. We have a huge number of technical notes covering all the common 
questions we are asked.

2.	 Call your reseller. Your reseller will have the latest technical updates from Blackmagic Design 
and should be able to give you immediate assistance. We also recommend you check out the 
support options your dealer offers as they can arrange various support plans based on your 
workflow requirements. Your reseller will also understand your disk array configuration, and as 
disk array problems account for around 90% of support questions with NLE systems, your reseller 
or disk array vendor will be able to provide expert help.

3.	 The next option is to email us with your questions using the web form at 
	 http://www.blackmagic-design.com/support/contact

4.	 Phone a Blackmagic Design support office. Please check our web site for current support phone 
numbers in your area. http://www.blackmagic-design.com/company/.

Note: Please provide us with as much information as possible regarding your technical problem and 
system specifications so that we may try to reproduce your problem quickly. Also please let us know 
how to reproduce any problem you’re having, so we can try it on our test systems before replying 
to your email.
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Connection Diagrams

Connection Diagrams

Connecting to a Betacam SP analog deck

This example shows DeckLink HD Extreme 2 connected to an analog deck for capture and playback 
to the deck. The HDMI and SDI outputs can be used for local monitoring.
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Connection Diagrams

Connection Diagrams

Connecting to an SDI digital deck

This example shows DeckLink HD Extreme 2 connected to a digital deck in 4:2:2 SD mode for 
capture and playback to the SDI deck. The HDMI, spare SDI and analog outputs can be used for 
local monitoring.
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DeckLink HD Extreme 2
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Connection Diagrams

Connection Diagrams

Connecting to a Sony HDCAM SR deck in 4:2:2

This example shows DeckLink HD Extreme 2 connected to a Sony HDCAM SR™ series digital 
deck in 4:2:2 HD mode for capture and playback to the HD-SDI deck. The HDMI, spare SDI and 
component analog outputs can be used for local monitoring of 4:2:2 HD video.
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Connection Diagrams

Connection Diagrams

Connecting to a Sony HDCAM SR deck in 4:2:2

This example shows DeckLink HD Pro PCIe connected to a Sony HDCAM SR™ series digital deck in 
4:2:2 HD mode. In this case, 2 HD-SDI connections are used for HD-SDI 4:2:2 video in and out. The 
component analog output can be used for local monitoring of 4:2:2 HD video.
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Connection Diagrams

Connection Diagrams

Connecting to a Sony HDCAM SR deck in 4:4:4

This example shows DeckLink HD Pro PCIe connected to a Sony HDCAM SR™ series digital deck in 
4:4:4 HD mode. In this case, 4 HD-SDI connections are used for dual-link HD-SDI 4:4:4 video in and 
out. The component analog output can be used for local monitoring of 4:4:4 HD video.
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Connection Diagrams

Connection Diagrams

Connecting to an NTSC/PAL monitor

This example shows DeckLink HD Extreme 2 connected to a standard definition Sony PVM monitor 
via composite analog video. Connect a BNC cable from DeckLink’s Y output cable to the composite 
analog video input of the Sony PVM monitor. You can use this for SD capture and playback monitoring 
with analog, SDI and HDMI video sources.
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Connection Diagrams

DeckLink HD Extreme 2 - connecting to S-Video
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This example shows the DeckLink HD Exteme Consumer Breakout Cable connecting to S-video 
adapter cables. The Professional Breakout Cable can also be used with S-video adapter cables. The 
numbering on the cables is the same on both the Consumer and Professional Breakout Cables so 
it’s easy to use either cable.
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Connection Diagrams
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Connection Diagrams

DeckLink HD Extreme - connecting to S-Video
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This example shows the DeckLink HD Exteme Consumer Breakout Cable connecting to S-video 
adapter cables. The Professional Breakout Cable can also be used with S-video adapter cables. The 
numbering on the cables is the same on both the Consumer and Professional Breakout Cables so 
it’s easy to use either cable.
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Connection Diagrams
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Connection Diagrams

Connecting to a YUV component monitor

This example shows DeckLink HD Extreme 2 connected to a multiformat Sony BVM monitor via 
component analog video. Connect three BNC cables from DeckLink’s Y, B-Y and R-Y output cables 
to the corresponding component analog inputs of the Sony BVM monitor. You can use this for SD 
or HD capture and playback monitoring with analog, SDI and HDMI video sources.
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Connection Diagrams
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Connection Diagrams

Connecting to an HDTV

This example shows DeckLink HD Extreme 2 connected to a consumer HDTV via HDMI. Connect a 
HDMI cable from DeckLink’s HDMI output to the HDMI input of the HDTV. You can use this for SD 
or HD capture and playback monitoring of analog, SDI and HDMI video sources.
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DeckLink HD Extreme 2
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Connection Diagrams

HDTV

Camera Outputs

Connection Diagrams

HDMI Workflow

DeckLink HD Extreme 2 can use HDMI for connecting video cameras, televisions and projectors 
to your computer for use with popular editing and design applications. DeckLink HD Extreme 2 
captures video in real-time directly from the HDMI output on HDV cameras, and will play back 
directly to large screen HDTVs or HD projectors for client-monitoring and editing.

Cards which can be used in this workflow

DeckLink HD Extreme 2
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Connection Diagrams
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Connection Diagrams

DeckLink HD Extreme 2 - monitoring via HDMI



39

Connection Diagrams
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Connection Diagrams

DeckLink HD Extreme 2 - 2K Monitoring with HDLink Pro
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Device Diagrams

Device Diagrams

DeckLink HD Extreme 2 and Professional Breakout Cable
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2.	 Deck Control

3.	 R-Y Out
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2K/HD/SD-SDI Output (to deck)

2K/HD/SD-SDI Input (from deck)
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9.	 B-Y In
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11.	 AES/EBU In

12.	 Audio Out Left

13.	 Audio Out Right

14.	 Audio In Left

15.	 Audio In Right

The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.
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Device Diagrams

Device Diagrams

DeckLink HD Extreme 2 and Consumer Breakout Cable
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9.	 B-Y In

10.	 AES/EBU Out

12.	 Audio Out Left

13.	 Audio Out Right

14.	 Audio In Left

15.	 Audio In Right

The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.
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DeckLink HD Extreme and Professional Breakout Cable
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DeckLink HD Extreme  
Professional Breakout Cable

2
3
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7
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14
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2.	 Deck Control

3.	 R-Y Out

HD/SD-SDI Monitoring Output

HD/SD-SDI Output (to deck)

HD/SD-SDI Input (from deck)

4.	 Y Out

5.	 B-Y Out

6.	 Ref In

7.	 R-Y In

8.	 Y In

9.	 B-Y In

10.	 AES/EBU Out

11.	 AES/EBU In

12.	 Audio Out Left

13.	 Audio Out Right

14.	 Audio In Left

15.	 Audio In Right

The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.
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DeckLink HD Extreme and Consumer Breakout Cable

DeckLink HD Extreme  
Consumer Breakout Cable
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7

8
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15

3.	 R-Y Out

HD/SD-SDI Monitoring Output

HD/SD-SDI Output (to deck)

HD/SD-SDI Input (from deck)

4.	 Y Out

5.	 B-Y Out

7.	 R-Y In

8.	 Y In

9.	 B-Y In

10.	 AES/EBU Out

12.	 Audio Out Left

13.	 Audio Out Right

14.	 Audio In Left

15.	 Audio In Right

2 3 4 5 6 7 8 9 10 11 12 13 14 15

2
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4
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The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.
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Deck Control RS-422

Reference In

HD/SD-SDI Output (to deck) 

HD/SD-SDI Input (from deck)

Device Diagrams

DeckLink SDI
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DeckLink Studio

DeckLink Studio Breakout Cable

HD/SD-SDI Output (to deck) 

HD/SD-SDI Input (from deck)

19

18

17

16

15

14

13

12

11

10

09

08

07

06

05

04

03

02

20

21

22

23

24

2.	 RS-422 Deck Control

3.	 Component Out

4.	 Component Out

5.	 Component Out

6.	 Genlock Tri-Sync In

7.	 Component In

8.	 Component In

9.	 Component In

10.	 AES / EBU Out

11.	 AES / EBU In

12.	 Analog Audio Out 1

16.	 Analog Audio In 1

14.	 Analog Audio Out 3 or AES / EBU In

18.	 Analog Audio In 3 or AES / EBU In

20.	 Composite In

22.	 S-Video In

13.	 Analog Audio Out 2

17.	 Analog Audio In 2

15.	 Analog Audio Out 4 or AES / EBU In

19.	 Analog Audio In 4 or AES / EBU In

21.	 Composite Out

23.	 S-Video Out

24.	 Standard Definition SDI Out
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Device Diagrams

DeckLink HD Pro PCIe

2.	 Deck Control

HD/SD-SDI Monitoring Output Ch A 

HD/SD-SDI Output (to deck) Ch B 

HD-SDI Input for 4:4:4 Ch B

HD/SD-SDI Input (from deck) Ch A

3.	 R-Y/R Monitor Out

4.	 Y/G Monitor Out

5.	 B-Y/B Monitor Out

6.	 Ref In

7.	 SPDIF/AES Out

8	 SPDIF/AES In

9.	 Wordclock Out

2

3

4

5

6

7

8

9

DeckLink HD Pro Breakout Cable
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DeckLink HD Pro PCI-X

2

3

4

5

6

7

8

9

2.	 Deck Control

HD/SD-SDI Monitoring Output Ch A

HD/SD-SDI Output (to deck) Ch B

HD-SDI Input for 4:4:4 Ch B

HD/SD-SDI Input (from deck) Ch A

3.	 R-Y/R Monitor Out

4.	 Y/G Monitor Out

5.	 B-Y/B Monitor Out

6.	 Ref In

7.	 SPDIF/AES Out

8.	 SPDIF/AES In

9.	 Wordclock Out

DeckLink HD Pro Breakout Cable
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DeckLink Extreme

Y Input 

R-Y Output

B-Y Output

Y Output 
(composite monitoring)

SD-SDI Input

SD-SDI Output

Genlock Input

Deck Control RS-422

DeckLink Extreme 
7ft Breakout Cable

B-Y Input 

R-Y Input 

AES-S/PDIF Output
(monitoring)

(L) Audio Input 
(balanced analog)

(L) Audio Output 
(balanced analog)

(R) Audio Input 
(balanced analog)

(R) Audio Output 
(balanced analog)

2

3

4

5

7

6

8

9

10

11

12

13

14

15

2.	 AES-S/PDIF Output
	 (monitoring)

3.	 (L) Audio Output 
	 (balanced analog)

6. 	 (R) Audio Input 
	 (balanced analog)

9. 	 R-Y Input

4. 	 (R) Audio Output 
	 (balanced analog)

7. 	 Y Input 

10. 	Y Output 
	 (composite monitoring)

5.  	 (L) Audio Input 
	 (balanced analog)

8. 	 B-Y Input 

11. 	B-Y Output

12. 	R-Y Output

13. 	SD-SDI Output

14. 	Genlock Input

15. 	SD-SDI Input

16. 	Deck Control RS-422

DeckLink Extreme  

Breakout Cable

16
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16

Y Input 

R-Y Output

B-Y Output

Y Output 
(composite monitoring)

SD-SDI Input

SD-SDI Output

Genlock Input

Deck Control RS-422

7ft break-out cable

B-Y Input 

R-Y Input 

SPDIF/AES Output
(monitoring)

(L) Audio Input 
(balanced analog)

(L) Audio Output 
(balanced analog)

(R) Audio Input 
(balanced analog)

(R) Audio Output 
(balanced analog)

2

3

4

5

7

6

8

9

10

11

12

13

14

15

2. 	 AES-S/PDIF Output
	 (monitoring)

3. 	 (L) Audio Output 
	 (balanced analog)

6. 	 (R) Audio Input 
	 (balanced analog)

9. 	 R-Y Input

4. 	 (R) Audio Output 
	 (balanced analog)

7. 	 Y Input 

10. 	Y Output 
	 (composite monitoring)

5.  	 (L) Audio Input 
	 (balanced analog)

8. 	 B-Y Input 

11. 	B-Y Output

12. 	R-Y Output

13. 	SD-SDI Output

14. 	Genlock Input

15. 	SD-SDI Input

DeckLink Extreme  

Breakout Cable

Device Diagrams

DeckLink Extreme PCIe

16. 	Deck Control RS-422
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15.	 Deck Control RS-422

Device Diagrams

DeckLink SP

7ft break-out cable

R-Y Input

B-Y Input

Y Input

R-Y Output

Genlock Input

Deck Control RS-422

SD-SDI Output
(monitoring)

SPDIF/AES Output
(monitoring)

(L) Audio Input 
(balanced analog)

(L) Audio Output 
(balanced analog)

B-Y Output

Y Output
(composite monitoring)

(R) Audio Input 
(balanced analog)

(R) Audio Output 
(balanced analog) 2

3

4

5

7

6

8

9

10

11

12

13

14

2. 	 AES-S/PDIF Output
	 (monitoring)

3. 	 (L) Audio Output 
	 (balanced analog)

6. 	 (R) Audio Input 
	 (balanced analog)

9. 	 R-Y Input

4. 	 (R) Audio Output 
	 (balanced analog)

7. 	 Y Input 

10. 	Y Output 
	 (composite monitoring)

5.  	 (L) Audio Input 
	 (balanced analog)

8. 	 B-Y Input 

11. 	B-Y Output

12. 	R-Y Output

13. 	SD-SDI Output 
	 (Monitoring)

14. 	Genlock Input

DeckLink SP 

Breakout Cable

15
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7ft break-out cable

R-Y Input

B-Y Input

Y Input

R-Y Output

Genlock Input

Deck Control RS-422

SD-SDI Output
(monitoring)

SPDIF Output
(monitoring)

(L) Audio Input 
(balanced analog)

(L) Audio Output 
(balanced analog)

B-Y Output

Y Output
(composite monitoring)

(R) Audio Input 
(balanced analog)

(R) Audio Output 
(balanced analog) 2

3

4

5

7

6

8

9

10

11

12

13

14

2.	 AES-S/PDIF Output
	 (monitoring)
3.	 (L) Audio Output 
	 (balanced analog)

6.	 (R) Audio Input 
	 (balanced analog)

9.	 R-Y Input

4.	 (R) Audio Output 
	 (balanced analog)

7.	 Y Input 

10.	 Y Output 
	 (composite monitoring)

5.	 (L) Audio Input 
	 (balanced analog)

8.	 B-Y Input 

11.	 B-Y Output

12.	 R-Y Output

13.	 SD-SDI Output 
	 (Monitoring)

14.	 Genlock Input

15.	 Deck Control RS-422

DeckLink SP 

Breakout Cable

15

Device Diagrams

DeckLink SP PCIe
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DeckLink Pro

7ft break-out cable

R-Y Output 
(monitoring)
B-Y Output 
(monitoring)
Y Output 
(composite monitoring)
SD-SDI Output 
(monitoring)

Genlock Input

Deck Control RS-422

SPDIF Output
(monitoring D)

SPDIF Output
(monitoring C)

SPDIF Output
(monitoring B)

SPDIF Output
(monitoring A)

SD-SDI Output 
(to deck)
SD-SDI Input 
(from deck)

8

9

10

11

12

13

DeckLink Pro 

Breakout Cable

2

3

4

6

5

7

8.	 SD-SDI Input

7.	 SD-SDI Output

10.	 Y Output 
	 (composite monitoring)

2.	 AES-S/PDIF Output A
	 (monitoring)
3.	 AES-S/PDIF Output B
	 (monitoring)

4.	 AES-S/PDIF Output C
	 (monitoring)
5.	 AES-S/PDIF Output D
	 (monitoring)

6.	 SDI-SDI Output
	 (Monitoring) 

11.	 B-Y Output
	 (Monitoring)
12.	 R-Y Output
	 (Monitoring)

9.	 Genlock Input

13.	 Deck Control RS-422
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Deck Control RS-422

SPDIF/AES Output

SD-SDI Output 
(Monitoring)

SD-SDI Output

SD-SDI Input 

Device Diagrams

DeckLink
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Developer Information

Blackmagic 2K Format

The latest Blackmagic Design products use the new 3 Gb/s SDI video, which allows twice the data 
rate of traditional HD-SDI video. We thought it would be a really nice idea to add 2K film support, via 
this new 3 Gb/s SDI technology, so we could simplify feature film workflows. With the popularity of 
Blackmagic Design editing systems worldwide, now thousands of people can benefit from a feature 
film workflow revolution.

This information includes everything product developers need to know for building native 2K SDI 
equipment. Of course, all Blackmagic products can be updated, so if the television industry adopts an 
alternative SDI-based film standard, we can add support for that too!

Frame Structure

Transmitted at 23.98 or 24 frames per second as a Progressive Segmented Frame. ��
Active video is 2048 pixels wide by 1556 lines deep. ��
Total lines per frame : 1650��
Words per active line. One word consists of a sample on both data streams: ��
3072 (2048*3/2). See following page.
Total active lines : 1556��
Words per total line : 3750.��
Fields per frame : 2, 825 lines each��
Active lines located on lines 16-793 (field 1) and 841-1618 (field 2).��

Transport Structure

Based on SMPTE S425M mapping structure 2.��

Timing reference signals, line number and line CRC insertion is the same as above.��

Optional ancillary data is inserted into both virtual interfaces.��

At present, only audio data is included: as per standard HD audio insertion (SMPTE S299M) the audio ��
data packets are carried on data stream two and audio control packets are carried on data stream one.

During active video, 10-bit Red, Green and Blue data is sent in the following sequence:��

	 Data stream1: Green_1, Red_1, Green_2, Green_3, Red_3, Green_4,…,Green_n-1, Red_n-1, Green_n.

	 Data stream 2: Blue_1, Red_2, Blue_2, Blue_3, Red_4, Blue_4, …,Blue_n-1, Red_n, Blue_n.

Diagrams on the following page show the vertical timing details with line numbers and Field, Vertical and 
Horizontal bits for the Timing Reference Signal codes. 

Final diagram shows the data stream formats around the optional ancillary data section of the horizontal 
line. Note that each active pixel takes up three samples.
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Warranty

3 Year Limited Warranty

Blackmagic Design warrants that this product will be free from defects in materials and workmanship 
for a period of 36 months from the date of purchase. If a product proves to be defective during this 
warranty period, Blackmagic Design, at its option, either will repair the defective product without 
charge for parts and labor, or will provide a replacement in exchange for the defective product. 

In order to obtain service under this warranty, you the Customer, must notify Blackmagic Design 
of the defect before the expiration of the warranty period and make suitable arrangements for 
the performance of service. The Customer shall be responsible for packaging and shipping the 
defective product to a designated service center nominated by Blackmagic Design, with shipping 
charges pre paid. Customer shall be responsible for paying all shipping changes, insurance, duties, 
taxes, and any other charges for products returned to us for any reason. 

This warranty shall not apply to any defect, failure or damage caused by improper use or improper 
or inadequate maintenance and care. Blackmagic Design shall not be obligated to furnish service 
under this warranty: a) to repair damage resulting from attempts by personal other than Blackmagic 
Design representatives to install, repair or service the product, b) to repair damage resulting from 
improper use or connection to incompatible equipment, c) to repair any damage or malfunction 
caused by the use of non Blackmagic Design parts or supplies, or d) to service a product that has 
been modified or integrated with other products when the effect of such a modification or integration 
increases the time or difficulty of servicing the product. THIS WARRANTY IS GIVEN BY BLACKMAGIC 
DESIGN IN LIEU OF ANY OTHER WARRANTIES, EXPRESS OR IMPLIED. BLACKMAGIC DESIGN 
AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE. BLACKMAGIC DESIGN’S RESPONSIBILITY TO REPAIR OR 
REPLACE DEFECTIVE PRODUCTS IS THE WHOLE AND EXCLUSIVE REMEDY PROVIDED TO 
THE CUSTOMER FOR ANY INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES 
IRRESPECTIVE OF WHETHER BLACKMAGIC DESIGN OR THE VENDOR HAS ADVANCE 
NOTICE OF THE POSSIBILITY OF SUCH DAMAGES. BLACKMAGIC DESIGN IS NOT LIABLE FOR 
ANY ILLEGAL USE OF EQUIPMENT BY CUSTOMER. BLACKMAGIC IS NOT LIABLE FOR ANY 
DAMAGES RESULTING FROM USE OF THIS  PRODUCT. USER OPERATES THIS PRODUCT AT 
OWN RISK. 

Copyright 2008 Blackmagic Design. All rights reserved. ‘Blackmagic Design’, ‘DeckLink’, ‘HDLink’, 
‘Workgroup Videohub’, ‘ Videohub’, ‘DeckLink’, ‘Intensity’ and ‘Leading the creative video 
revolution’ are registered trademarks in the US and other countries. All other company and product 
names may be trade marks of their respective companies with which they are associated.


